#1 18-06-2020 20:28:04

Kaskager
user
Здесь с 18-06-2020
Сообщений: 1
AndroidChrome 83.0

Подскажи, что делаю не правильно?

Добрый день , такая проблема , хочу установить дистрибутив себе на ноутбук второй системой , скачал образ , руфусом записал , выбрал установку системы , дошло до разметки диска , и выбрал ручная разметка.Сжал диск d и освободил место и разметил следующим образом , создал корневой раздел / , затем раздел хоум, раздел  бут/uefi , выделив последний созданный диск продолжал установку , установка закончилась , перезагружаю и горит grub (командная строка)что я делаю не так ????

Вне форума

#2 25-06-2020 02:33:17

goblin
user
Откуда: Россия
Здесь с 23-04-2020
Сообщений: 18
Windows 10Chrome 80.0

Re: Подскажи, что делаю не правильно?

я напишу как делал я. правда не с ctlos, а с fedora а потом rosa. но не суть. принцип одинаков. изначально windows на весь диск установлен. брал Eassos PartitionGuru 4.9.5.508. новыми версиями не пробовал. наверно тоже самое. уменьшал раздел диска с виндовс освобождая ~50gb не размеченного пространства. загружался потом с live-флешки с fedora и при установки просто указывал на ту пустую область в 50gb. дальше все само прописывалось и размечалось...

есть один момент. у меня ноут старенький lenovo g480. в нем я в биосе отключал uefi перед установкой linux. иначе система так прописывалась, что в настройки биос потом не зайти. приходилось перепрошивать биос.
есть второй момент. не знаю как сейчас, а когда я баловался установками дистров linux. calamares не ставил boot флаг на раздел. из-за этого система не загружалась.

Вне форума

#3 25-06-2020 19:13:10

creio
super_root
Здесь с 16-04-2020
Сообщений: 29
Сайт
LinuxChrome 83.0

Re: Подскажи, что делаю не правильно?

goblin пишет:

calamares не ставил boot флаг на раздел. из-за этого система не загружалась.

А сами почему не указываете флаги, в нем это же есть, или имеется ввиду, что он игнорит ваш выбор. На сколько я знаю он даже без указания флагов справляется с boot.


Мы используем Linux каждый день, и наша продуктивность пошла в гору! Так что пошли бы и вы..!
— Joe Sloan

Вне форума

#4 25-06-2020 23:30:09

goblin
user
Откуда: Россия
Здесь с 23-04-2020
Сообщений: 18
Windows 10Chrome 80.0

Re: Подскажи, что делаю не правильно?

creio пишет:

А сами почему не указываете флаги

а где? я указывал calamares пустую не размеченную область. дальше все делалось само. никаких предложений что-то указать. потом я уже прочитал на github, что на mbr дисках на системах с отключенным uefi calamares "забывает" поставить boot флаг. был там такой тикет. потому система и не грузится. загружался с live и gparted ставил этот флаг. и только тогда установленная система запускалась.


нашел https://github.com/calamares/calamares/issues/1175

Добавлено спустя 30 мин 22 с:

creio пишет:

На сколько я знаю он даже без указания флагов справляется с boot.

не на всех биос это работает. а вот с флагом биос "видит" что грузить.

Отредактировано goblin (25-06-2020 23:40:24)

Вне форума

Сейчас в этой теме пользователей: 0, гостей: 1
[Bot] CCBot

Подвал форума

Powered by FluxBB
Modified by Visman & creio

[ Сгенерировано за 0.089 сек, 7 запросов выполнено - Использовано памяти: 698.46 Кбайт (Пик: 737.01 Кбайт) ]